关于intel处理器存在设计漏洞后续说明的安全公告 -买球的app排行榜

北京安信天行科技有限公司(以下简称axtx)通过对互联网安全漏洞相关信息的跟踪,2018年1月3日,谷歌发布了一则新闻,他们的 project zero 研究者发现了meltdown 和spectre两组cpu级别的漏洞,此漏洞会导致低权限应用访问到内核内存,linux以及windows不得不大幅改动、重新设计内核,才能解决这个芯片级的安全漏洞。
  • 漏洞详细描述
google公司的project zero等安全团队披露出的英特尔等处理器芯片存在非常严重的安全漏洞,将其命名为meltdown和spectre。
meltdown漏洞编号为cve-2017-5754(rogue data cache load);
spectre漏洞编号为cve-2017-5715(branch target injection),cve-2017-5753(bounds check bypass);
两组漏洞几乎影响了所有主流cpu,其中就包括了 amd、arm 和 intel。
同时,云端设备、pc、笔记本、平板和智能手机都受到了波及,恶意者可利用这些漏洞来窃取计算机上的敏感数据。
meltdown 攻击
meltdown漏洞利用到了无序执行指令(out-of-order)模式,可允许恶意者读取目标设备的整个物理内存空间,而不单是内核空间,从而泄露出操作系统及其上应用程序的所有信息。利用程序中借助了处理器提权漏洞,使得指令可以绕过内存保护,从而由“推演执行”特性绕过用户层到内核层的限制,这就使得应用程序也能访问系统为内核分配的空间。
spectre 攻击
要完全解决 spectre 漏洞需改变处理器的架构,因此该漏洞不容易修补且会困扰人们很长一段时间。
它打破了不同进程间的隔离机制,攻击者会先让进程访问其内部的特定空间,而后通过侧信道方式读取相应数据,从而泄露出程序信息。
spectre 攻击不仅可以用于内核层到用户层的信息泄露,还可用于虚拟化中 hypervisor 层到 client 层的信息泄漏。此外,借助 js 代码还可实现浏览器沙箱逃逸。
 
利用场景概述
meltdown和spectre两类攻击方式实际上利用了现代cpu中用于提升执行性能的两种并行执行特性:乱序执行(out-of-order execution)和推测执行(speculative execution)。
表面上看,处理器是依次顺序执行既定的处理器指令。但是现代cpu为了更好利用处理器资源,使用了并行执行技术,该技术已经应用了20年左右(1995年开始)。假设,基于猜测或概率的角度,在当前的指令或分支还未执行完成前就开始执行可能会被执行的指令或分支,会发生什么?如果猜对了,直接使用,cpu执行加速了。如果猜测不正确,则取消操作并恢复到原来的现场(寄存器,内存等),结果会被忽略。
不幸的是,不管预测是否正确,cpu缓存中依然保留了推测执行中访问的内存数据,并且由于推测执行的过程是不受权限检测的(cpu在推测执行过程中不会进行权限检测,比如推测执行的应用层代码可以读取内核地址数据)。如果攻击者能触发推测执行去访问指定的敏感数据区域的数据,就可能读取到原本是其它用户或更高特权级的敏感数据,虽然这些越权读取的数据存储在cpu的缓存中,并且用户代码无权访问,但是通过一种低噪的侧信道攻击技巧可以“猜测”出越权读取的数据,从而造成严重的信息泄露。
 
推测攻击场景
此外,猜测过程是可以被“污染”的,攻击者可以构造出类似rop攻击的逻辑去影响推测过程。根据作者提供的思路,主要有三种场景:
1、“边界检查绕过”:通过污染分支预测,来绕过kernel或hypervisor的内存对象边界检测。比如,攻击者可以对高权级的代码段,或虚拟环境中hypercall,通过构造的恶意代码来触发有越界的数据下标,造成越界访问;
2、“分支目标注入”: 污染分支预测。抽象模型比较好的代码往往带有间接函数指针调用的情况,cpu在处理时需要会进行必要的内存访问,这个过程有点慢,所以cpu会预测分支。攻击者可以通过类似的rop的方式来进行信息泄露;
3、“流氓数据加载”:部分cpu上,为了速度并不是每次都对指令作权限检查的,检查的条件存在一定的缺陷。
 
实际攻击场景中,攻击者在一定条件下可以做到:
泄露出本地操作系统底层运作信息,秘钥信息等;
通过获取泄露的信息,可以绕过内核(kernel), 虚拟机超级管理器(hypervisor)的隔离防护;
云服务中,可以泄露到其它租户隐私信息;
通过浏览器泄露受害者的帐号,密码,内容,邮箱, cookie等用户隐私信息;
 
修复漏洞将对性能造成影响
该漏洞无法通过芯片的微码(microcode)更新进行修复,各厂商需要对操作系统的内核关键部分做一定的修改来解决,而修复该漏洞会牺牲5%-30%的相关性能。针对云厂商主机,漏洞修补后将会影响i/o性能,不影响主机计算性能;而对于个人电脑的性能影响不是很大。
  • 漏洞来源
  1. https://newsroom.intel.com/news/intel-responds-to-security-research-findings/
  2. https://portal.msrc.microsoft.com/en-us/security-guidance
  3. https://www.anquanke.com/post/id/93455
  4. http://www.cve.mitre.org/cgi-bin/cvename.cgi?name=2017-5715(可将cve编号替换于此)
三、漏洞影响范围
本次漏洞影响范围非常广泛,包括:
处理器芯片:英特尔为主、arm、amd,对其他处理器同样可能存在相关风险;
操作系统:windows、linux、macos、android;
云服务提供商:亚马逊、微软、谷歌、腾讯云、阿里云等;
各种私有云基础设施。
桌面用户可能遭遇到结合该机理组合攻击。
受影响cpu列表:
厂商 型号 meltdown漏洞 spectre漏洞
intel intel® core™ i3 processor (45nm and 32nm) y y
intel® core™ i5 processor (45nm and 32nm) y y
intel® core™ i7 processor (45nm and 32nm) y y
intel® core™ m processor family (45nm and 32nm) y y
2nd generation intel® core™ processors y y
3rd generation intel® core™ processors y y
4th generation intel® core™ processors y y
5th generation intel® core™ processors y y
6th generation intel® core™ processors y y
7th generation intel® core™ processors y y
8th generation intel® core™ processors y y
intel® core™ x-series processor family for intel® x99 platforms y y
intel® core™ x-series processor family for intel® x299 platforms y y
intel® xeon® processor 3400 series y y
intel® xeon® processor 3600 series y y
intel® xeon® processor 5500 series y y
intel® xeon® processor 5600 series y y
intel® xeon® processor 6500 series y y
intel® xeon® processor 7500 series y y
intel® xeon® processor e3 family y y
intel® xeon® processor e3 v2 family y y
intel® xeon® processor e3 v3 family y y
intel® xeon® processor e3 v4 family y y
intel® xeon® processor e3 v5 family y y
intel® xeon® processor e3 v6 family y y
intel® xeon® processor e5 family y y
intel® xeon® processor e5 v2 family y y
intel® xeon® processor e5 v3 family y y
intel® xeon® processor e5 v4 family y y
intel® xeon® processor e7 family y y
intel® xeon® processor e7 v2 family y y
intel® xeon® processor e7 v3 family y y
intel® xeon® processor e7 v4 family y y
intel® xeon® processor scalable family y y
intel® xeon phi™ processor 3200, 5200, 7200 series y y
intel® atom™ processor c series y y
intel® atom™ processor e series y y
intel® atom™ processor a series y y
intel® atom™ processor x3 series y y
intel® atom™ processor z series y y
intel® celeron® processor j series y y
intel® celeron® processor n series y y
intel® pentium® processor j series y y
intel® pentium® processor n series y y
arm cortex-r7 n y
cortex-r8 n y
cortex-a8 n y
cortex-a9 n y
cortex-a15 n y
cortex-a17 n y
cortex-a57 n y
cortex-a72 n y
cortex-a73 n y
cortex-a75 y y
amd 锐龙 n y
锐龙pro n y
锐龙threadripper  n y
ryzen n y
a系列 n y
皓龙 n y
霄龙 n y
说明:
1.y代表存在对应漏洞,n代表不存在对应漏洞。
2.不出现在列表的上诉厂商设备将很可能不受到影响。
四、安全处理建议
一、相关的安全补丁及修复方案。
硬件厂商
(1)intel:
https://security-center.intel.com/advisory.aspx?intelid=intel-sa-00088&languageid=en-fr
公告包含了受影响设备,基本覆盖了目前市面的所有intel cpu产品。
(2)amd:
https://www.amd.com/en/corporate/speculative-execution
amd处理器拥有内核页表隔离功能,据称仅受 spectre影响而不受meltdown影响。
(3)nvidia:
https://forums.geforce.com/default/topic/1033210/nvidias-response-to-speculative-side-channels-cve-2017-5753-cve-2017-5715-and-cve-2017-5754/
公告表示确信不受影响并通过更新gpu驱动帮助cpu出现的安全问题。
(4)arm:
https://developer.arm.com/support/security-update
部分arm处理器受影响,其中大部分受到spectre漏洞影响,而极少受到meltdown漏洞影响。
操作系统厂商:
(1)android:
https://source.android.com/security/bulletin/2018-01-01
通过减少了对高精度定时器的访问来限制旁路攻击。
(2)windows:
https://portal.msrc.microsoft.com/en-us/security-guidance/advisory/adv180002
微软本次更新应该是解决了meltdown 漏洞,对于spectre漏洞仅做了缓解。
但部分用户在更新时遇到了一些问题,其meltdown 和 spectre 安全更新似乎与反病毒软件们相处得并不融洽。在测试中发现,部分第三方应用程序已经对windows内核内存进行了不受支持的调用,更新导致蓝屏错误的发生,让设备无法boot。
如果用户在自己系统的windows更新功能中看到“检查更新”有新内容,则可以进行安装。不同的系统会有不同的补丁kb编号,主要是系统和硬件平台差别导致的。如果没有新内容出现,则意味着windows检查到该用户的电脑上存在不兼容的反病毒软件!
微软表示他们已经在和各种厂商进行了沟通,部分不兼容的产品需要创建一个注册表项目,确保不会在本次安全更新后系统崩溃。
    但在本次补丁安装时,系统会自动检测注册表项是否存在;如果键值存在,windows更新进程才会相信反病毒软件已经得到更新,可以兼容补丁,系统才能正确更新。——这里就是问题点
部分厂商表示他们不打算创建这个注册表值,部分厂商表示自己无法在“技术上”实现,其他厂商则在之后的几天内会将自己的av产品更新,满足要求。
所以,如果用户使用的反病毒软件不巧处在“无法添加注册表项”的一类中,可以通过如下步骤实现更新:
请在再三确认自己的厂商是否兼容,不兼容的话,才建议使用这个 .reg 文件!
key="hkey_local_machine" subkey="software\microsoft\windows\currentversion\qualitycompat" value="cadca5fe-87d3-4b96-b7fb-a231484277cc" type="reg_dword”
运行文件或者手动添加注册表项后,就可以正常安装微软补丁了
安全更新和杀毒软件的兼容性问题可以参考:
https://docs.google.com/spreadsheets/d/184wcdt9i9tunffbsavlpzatckqxyiuiradzf3cl42fq/htmlview?sle=true#gid=0。
(3)mac os&ios:
https://support.apple.com/en-us/ht208394
苹果已经在 ios 11.2、macos 10.13.2 和 tvos 11.2 上发布了修复措施,以应对 meltdown。并称计划在 safari 中发布修复方案,应对 spectre 漏洞。
(4)linux:
如下版本均以发布更新具体细节可通过公告查看。
red hat:
https://access.redhat.com/security/vulnerabilities/speculativeexecution?sc_cid=701f2000000tslnaay
debian:
https://security-tracker.debian.org/tracker/cve-2017-5754
ubuntu:
https://security-tracker.debian.org/tracker/cve-2017-5754
suse:
https://www.suse.com/c/suse-addresses-meltdown-spectre-vulnerabilities/
虚拟化:
(1)vmware:
https://www.vmware.com/us/security/advisories/vmsa-2018-0002.html
esxi,workstation,fusion均已发布更新。
(2)xen:
https://xenbits.xen.org/xsa/advisory-254.html
目前还没有更新发布,但是对于sp1和sp2可以开启smep来环境漏洞被利用。
(3)citrix:
https://support.citrix.com/article/ctx231399
citrix netscaler sdx和citrix xenserver被指出受到影响。citrix xenmobile server和citrix netscaler (mpx/vpx)被确认不受影响,部分已经提供更新。
云服务厂商:
(1)亚马逊云修复工作已到尾声
https://aws.amazon.com/cn/security/security-bulletins/aws-2018-013/
(2)腾讯云将于1月10日凌晨通过热升级方式对虚拟化平台底层进行修复
http://bbs.qcloud.com/thread-48531-1-1.html
(3)阿里云已经启动了云平台底层基础架构的漏洞修复更新,会根据批次依次修复,最迟于北京时间1月12日24点之前完成
https://help.aliyun.com/noticelist/articleid/20700730.html?spm=5176.789004748.n2.6.nqn44f
(4)金山云与买球平台网址的合作伙伴intel就此问题已进行协商
https://www.ksyun.com/news/art/id/2138
(5)ucloud已开展修复工作,具体时间未定
http://blog.ucloud.cn/archives/2991
(6)青云在密切观察并与 intel 保持持续沟通
https://log.qingcloud.com/archives/3599
二、检测方法
1、windows用户
1月3日深夜,微软发布了针对meltdown和specter的系统安全更新,而两个安全漏洞影响了几乎所有自1995年以来发布的cpu(不止intel)。根据微软的安全建议来看,这些 windows 安全更新能够解决了各种windows 发行版中的meltdown和spectre漏洞。
微软发布了一个powershell来检查是否安装了正确的更新程序,或是否需要额外的固件更新。
用户在启动powershell时,请确保是以管理员权限启动的,以便安装所需的模块。
 
下面的powershell命令,将下载并安装powershell模块,用于测试meltdown和specter的缺陷。
install-module speculationcontrol
如果用户运行该命令返回的是错误,则可以运行以下命令:
set-executionpolicy bypass
然后,用户可以运行第二条命令:
get-speculationcontrolsettings
如果在运行get-speculationcontrolsettings时出现如下错误,需要开启脚本执行权限,且需要将speculationcontrol模块导入。
命令如下:
 
set-executionpolicy  remotesigned
import-module  speculationcontrol
如果用户在运行这些命令后看到很多红色的文字,那么可以确认该用户的cpu处在威胁之中。例:

安装补丁后再执行get-speculationcontrolsettings命令有两种可能的情况:
 
此为最常见的,意思是说 meltdown补丁已经成功,但是spectre漏洞修复不完整。红色的文字内容是指改名用户还是需要额外的芯片组固件更新。如果用户的笔记本电脑/台式机/服务器供应商提供了额外的芯片组固件更新,他们可以从官方站点获取,安装并完成修补程序。
如果一切正常,所有检查将以绿色文本显示,如下所示:
 
github也有公开的检测工具:
https://github.com/ionescu007/specucheck
2、linux用户
https://github.com/raphaelsc/am-i-affected-by-meltdown
以下测试工具可以编译后运行在64位linux系统下。
地址:https://github.com/paboldin/meltdown-exploit
3、其他较为通用的工具及poc代码特征
https://github.com/viralmaniar/in-spectre-meltdown
https://github.com/realjtg/meltdown
https://github.com/eugnis/spectre-attack
https://github.com/feruxmax/meltdown
https://github.com/gkaindl/meltdown-poc
https://github.com/turbo/kpti-poc-collection
https://github.com/dendisuhubdy/meltdown
https://github.com/harsaroopdhillon/meltdow
https://github.com/paboldin/meltdown-exploit
https://github.com/feruxmax/meltdown
https://github.com/corsix/meltdown-poc
https://github.com/ssstonebraker/meltdown_specre
https://github.com/cloudsriseup/meltdown-proof-of-concept
https://github.com/sampuka/meltdown
https://github.com/douyamv/meltdowntool
https://github.com/gentilkiwi/spectre_meltdown
https://github.com/willyb321/meltdown-spectre-poc-grabber
https://github.com/mniip/spectre-meltdown-poc
https://github.com/1nf0rmed/meltdownexploit
 
现已出现该漏洞的在野攻击,对于此漏洞望多加关注。
 
若需要进一步获得有关安全咨询,欢迎垂询北京安信天行科技有限公司安全服务专家。
 
联系电话:58543888
邮箱地址:[email protected]
 
北京安信天行科技有限公司  云安全中心
2018年1月8日